System requirements

Requirements

Microsoft Windows 98SE/2000/XP/Vista
USB2.0 or 1.1 compatibile – pre 98 systems may need additional drivers

*VIN support and product updates require an internet browser

Comments are closed